import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">([-+]?\\d[\\d,.]*)<";
final String string = "[\"FL gr_20 T3\\'><strong>+1,921.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>-921.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>21.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>1,11,921.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>1,921</strong>\"]' st='[\"FL gr_20 T3\\'><strong>112921</strong>\"]' st='[\"FL gr_20 T3\\'><strong>1.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>1</strong>\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}