re = />([-+]?\d[\d,.]*)</m
str = '["FL gr_20 T3\\\'><strong>+1,921.15</strong>"]\' st=\'["FL gr_20 T3\\\'><strong>-921.15</strong>"]\' st=\'["FL gr_20 T3\\\'><strong>21.15</strong>"]\' st=\'["FL gr_20 T3\\\'><strong>1,11,921.15</strong>"]\' st=\'["FL gr_20 T3\\\'><strong>1,921</strong>"]\' st=\'["FL gr_20 T3\\\'><strong>112921</strong>"]\' st=\'["FL gr_20 T3\\\'><strong>1.15</strong>"]\' st=\'["FL gr_20 T3\\\'><strong>1</strong>"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end