import re
regex = re.compile(r">([-+]?\d[\d,.]*)<", flags=re.MULTILINE)
test_str = "[\"FL gr_20 T3\\'><strong>+1,921.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>-921.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>21.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>1,11,921.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>1,921</strong>\"]' st='[\"FL gr_20 T3\\'><strong>112921</strong>\"]' st='[\"FL gr_20 T3\\'><strong>1.15</strong>\"]' st='[\"FL gr_20 T3\\'><strong>1</strong>\"]"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")