const regex = new RegExp('>([-+]?\\d[\\d,.]*)<', 'gm')
const str = `["FL gr_20 T3\\'><strong>+1,921.15</strong>"]' st='["FL gr_20 T3\\'><strong>-921.15</strong>"]' st='["FL gr_20 T3\\'><strong>21.15</strong>"]' st='["FL gr_20 T3\\'><strong>1,11,921.15</strong>"]' st='["FL gr_20 T3\\'><strong>1,921</strong>"]' st='["FL gr_20 T3\\'><strong>112921</strong>"]' st='["FL gr_20 T3\\'><strong>1.15</strong>"]' st='["FL gr_20 T3\\'><strong>1</strong>"]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}