#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(\d+)\s*)?(A|B|DF|XY)(?:\s*(\d+))?$"
Local $sString = "A1234" & @CRLF & _
"B 1239" & @CRLF & _
"1A123" & @CRLF & _
"12A123" & @CRLF & _
"1A 1234" & @CRLF & _
"12 A 123" & @CRLF & _
"1234 B 123456789" & @CRLF & _
"12 XY 1234567890"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")