re = /^(?:(\d+)\s*)?(A|B|DF|XY)(?:\s*(\d+))?$/m
str = 'A1234
B 1239
1A123
12A123
1A 1234
12 A 123
1234 B 123456789
12 XY 1234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end