const regex = /^(?:(\d+)\s*)?(A|B|DF|XY)(?:\s*(\d+))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(\\d+)\\s*)?(A|B|DF|XY)(?:\\s*(\\d+))?$', 'gm')
const str = `A1234
B 1239
1A123
12A123
1A 1234
12 A 123
1234 B 123456789
12 XY 1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}