import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(\\d+)\\s*)?(A|B|DF|XY)(?:\\s*(\\d+))?$";
final String string = "A1234\n"
+ "B 1239\n"
+ "1A123\n"
+ "12A123\n"
+ "1A 1234\n"
+ "12 A 123\n"
+ "1234 B 123456789\n"
+ "12 XY 1234567890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}