#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<![-\d])(?<!\d[.,])(?!0+(?!\d))\d*[24680](?![.,]?\d)"
Local $sString = "a1q2q3a12a234a478a445a10.7d44456s10,6s-8s-6s145f667s10k0щ00212а0002220mm00000д00200"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")