const regex = /(?<![-\d])(?<!\d[.,])(?!0+(?!\d))\d*[24680](?![.,]?\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![-\\d])(?<!\\d[.,])(?!0+(?!\\d))\\d*[24680](?![.,]?\\d)', 'gm')
const str = `a1q2q3a12a234a478a445a10.7d44456s10,6s-8s-6s145f667s10k0щ00212а0002220mm00000д00200`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}