import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![-\\d])(?<!\\d[.,])(?!0+(?!\\d))\\d*[24680](?![.,]?\\d)";
final String string = "a1q2q3a12a234a478a445a10.7d44456s10,6s-8s-6s145f667s10k0щ00212а0002220mm00000д00200";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}