$re = '/(?<![-\d])(?<!\d[.,])(?!0+(?!\d))\d*[24680](?![.,]?\d)/m';
$str = 'a1q2q3a12a234a478a445a10.7d44456s10,6s-8s-6s145f667s10k0щ00212а0002220mm00000д00200';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);