using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:(?!-)[a-zA-Z0-9-]{1,63}(?<!-)\.)+[a-zA-Z]{2,63})";
string input = @"HostRegexp(`vsdf-dev.example.com`) && PathPrefix(`/ui/`)
HostRegexp(`svwd-dev.example.com`,`cvwf-a-dev.example.com`,`fwsfw-dev.example.com`) && PathPrefix(`/api/`)
Host(`xfwdev.example.com`) && PathPrefix(`/boot-admin/`)
Host(`*`) && PathPrefix(`/api/THAI`)
Host(`dev.example.com`,`dfwdwf.examplexxx.org.jp`) && PathPrefix(`/api/health`,`/api/manage/health`,`/api/manage/features`,`/api/manage/info`)
Host(``) && PathPrefix(`/api/short`)
Host(`\u003cno value\u003e`) && PathPrefix(`/`)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}