re = /((?:(?!-)[a-zA-Z0-9-]{1,63}(?<!-)\.)+[a-zA-Z]{2,63})/m
str = 'HostRegexp(`vsdf-dev.example.com`) && PathPrefix(`/ui/`)
HostRegexp(`svwd-dev.example.com`,`cvwf-a-dev.example.com`,`fwsfw-dev.example.com`) && PathPrefix(`/api/`)
Host(`xfwdev.example.com`) && PathPrefix(`/boot-admin/`)
Host(`*`) && PathPrefix(`/api/THAI`)
Host(`dev.example.com`,`dfwdwf.examplexxx.org.jp`) && PathPrefix(`/api/health`,`/api/manage/health`,`/api/manage/features`,`/api/manage/info`)
Host(``) && PathPrefix(`/api/short`)
Host(`\\u003cno value\\u003e`) && PathPrefix(`/`)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end