Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
((?:(?!-)[a-zA-Z0-9-]{1,63}(?<!-)\.)+[a-zA-Z]{2,63})
"
gm
Input 1
1
New
HostRegexp(`vsdf-dev.example.com`) && PathPrefix(`/ui/`) HostRegexp(`svwd-dev.example.com`,`cvwf-a-dev.example.com`,`fwsfw-dev.example.com`) && PathPrefix(`/api/`) Host(`xfwdev.example.com`) && PathPrefix(`/boot-admin/`) Host(`*`) && PathPrefix(`/api/THAI`) Host(`dev.example.com`,`dfwdwf.examplexxx.org.jp`) && PathPrefix(`/api/health`,`/api/manage/health`,`/api/manage/features`,`/api/manage/info`) Host(``) && PathPrefix(`/api/short`) Host(`\u003cno value\u003e`) && PathPrefix(`/`)