using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[a-z0-9]+|[A-Z0-9]+[a-z0-9]*|[0-9]+";
string input = @"managedReferenceExample
ManagedReferenceExample
HTMLFile
antl3rParser
Direct3DWrapper <-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}