$re = '/[a-z0-9]+|[A-Z0-9]+[a-z0-9]*|[0-9]+/m';
$str = 'managedReferenceExample
ManagedReferenceExample
HTMLFile
antl3rParser
Direct3DWrapper <-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);