re = /[a-z0-9]+|[A-Z0-9]+[a-z0-9]*|[0-9]+/m
str = 'managedReferenceExample
ManagedReferenceExample
HTMLFile
antl3rParser
Direct3DWrapper <-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end