package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[a-z0-9]+|[A-Z0-9]+[a-z0-9]*|[0-9]+`)
var str = `managedReferenceExample
ManagedReferenceExample
HTMLFile
antl3rParser
Direct3DWrapper <-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}