const regex = /^https:\/\/neculaifantanaru.com\/en([^\/]|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https:\\\/\\\/neculaifantanaru.com\\\/en([^\\\/]|$)', 'gm')
const str = `https://neculaifantanaru.com/en/the-continuity-of-the-work-of-art.html
https://neculaifantanaru.com/enthe-continuity-of-the-work-of-art.html
https://neculaifantanaru.com/azerbaijan.html
https://neculaifantanaru.com/en`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}