$re = '/^https:\/\/neculaifantanaru.com\/en([^\/]|$)/m';
$str = 'https://neculaifantanaru.com/en/the-continuity-of-the-work-of-art.html
https://neculaifantanaru.com/enthe-continuity-of-the-work-of-art.html
https://neculaifantanaru.com/azerbaijan.html
https://neculaifantanaru.com/en';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);