// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https:\/\/neculaifantanaru.com\/en([^\/]|$)").unwrap();
let string = "https://neculaifantanaru.com/en/the-continuity-of-the-work-of-art.html
https://neculaifantanaru.com/enthe-continuity-of-the-work-of-art.html
https://neculaifantanaru.com/azerbaijan.html
https://neculaifantanaru.com/en";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}