# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^https:\/\/neculaifantanaru.com\/en([^\/]|$)"
test_str = ("https://neculaifantanaru.com/en/the-continuity-of-the-work-of-art.html\n"
"https://neculaifantanaru.com/enthe-continuity-of-the-work-of-art.html\n"
"https://neculaifantanaru.com/azerbaijan.html\n"
"https://neculaifantanaru.com/en")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.