import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d{2}\\.\\d+";
final String string = "Добрый день.\n"
+ "Как сформировать регулярное приложение, чтобы из подобного массива можно было вытаскивать координаты.\n"
+ "[3] => 17629,17629,\"ПОНТОННЫЙ, ВОКЗАЛ\",59.785067,30.627792,0,2,bus\n"
+ "[4] => 17630,17630,ДОРОГА НА КОЛПИНО,59.775908,30.653787,0,2,bus\n"
+ "К примеру чтобы я получил массив \n"
+ "[0] => 59.785067\n"
+ "[1] => 30.627792";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}