$re = '@\d{2}\.\d+@';
$str = 'Добрый день.
Как сформировать регулярное приложение, чтобы из подобного массива можно было вытаскивать координаты.
[3] => 17629,17629,"ПОНТОННЫЙ, ВОКЗАЛ",59.785067,30.627792,0,2,bus
[4] => 17630,17630,ДОРОГА НА КОЛПИНО,59.775908,30.653787,0,2,bus
К примеру чтобы я получил массив
[0] => 59.785067
[1] => 30.627792';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);