import re
regex = re.compile(r"\d{2}\.\d+")
test_str = ("Добрый день.\n"
"Как сформировать регулярное приложение, чтобы из подобного массива можно было вытаскивать координаты.\n"
"[3] => 17629,17629,\"ПОНТОННЫЙ, ВОКЗАЛ\",59.785067,30.627792,0,2,bus\n"
"[4] => 17630,17630,ДОРОГА НА КОЛПИНО,59.775908,30.653787,0,2,bus\n"
"К примеру чтобы я получил массив \n"
"[0] => 59.785067\n"
"[1] => 30.627792")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")