# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=sid=\\\")\d+(?=\\\")/a/gm;t' <<< "sid=\\"1722407313768658\\" safklabsf ipashf oiasfoi asbg fasnk sid=\\"65641\\" asjobfaosb asbfaosb asf asfauv sid=\\"651564165\\" aosibfoasbfoaibsfopaih l;fasbf oiasbfoabop iasbfabsfiogaosuf ou agosufg iuagfi uaf sid=\\"4191891\\" auoegfaouf ouah aisfbag iuaeh sid=\\"51951981\\". afa[sof afsoi9ha [h .sid=\\"16518198819198\\". asfoiiha h'sid=\\"651848949871698189\\".
sid=\\"54637837834534534\\"
sid=\\"172240735345313768658\\"
sid=\\"453453453453\\".
sid=\\"453453453453453\\".sid=\\"4535453453453453453\\"
sid=\\"786783453533453453\\"
s[dohj
aspiofbaspfppsid=\\"453453453453453453453\\""