#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=sid=\\\")\d+(?=\\\")"
Local $sString = "sid=\"1722407313768658\" safklabsf ipashf oiasfoi asbg fasnk sid=\"65641\" asjobfaosb asbfaosb asf asfauv sid=\"651564165\" aosibfoasbfoaibsfopaih l;fasbf oiasbfoabop iasbfabsfiogaosuf ou agosufg iuagfi uaf sid=\"4191891\" auoegfaouf ouah aisfbag iuaeh sid=\"51951981\". afa[sof afsoi9ha [h .sid=\"16518198819198\". asfoiiha h'sid=\"651848949871698189\"." & @CRLF & _
"" & @CRLF & _
"sid=\"54637837834534534\"" & @CRLF & _
"sid=\"172240735345313768658\"" & @CRLF & _
"sid=\"453453453453\"." & @CRLF & _
"sid=\"453453453453453\".sid=\"4535453453453453453\"" & @CRLF & _
"" & @CRLF & _
"sid=\"786783453533453453\"" & @CRLF & _
"s[dohj" & @CRLF & _
"aspiofbaspfppsid=\"453453453453453453453\""
Local $sSubst = "a"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)