import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=sid=\\\\\\\")\\d+(?=\\\\\\\")";
final String string = "sid=\\\"1722407313768658\\\" safklabsf ipashf oiasfoi asbg fasnk sid=\\\"65641\\\" asjobfaosb asbfaosb asf asfauv sid=\\\"651564165\\\" aosibfoasbfoaibsfopaih l;fasbf oiasbfoabop iasbfabsfiogaosuf ou agosufg iuagfi uaf sid=\\\"4191891\\\" auoegfaouf ouah aisfbag iuaeh sid=\\\"51951981\\\". afa[sof afsoi9ha [h .sid=\\\"16518198819198\\\". asfoiiha h'sid=\\\"651848949871698189\\\".\n\n"
+ "sid=\\\"54637837834534534\\\"\n"
+ "sid=\\\"172240735345313768658\\\"\n"
+ "sid=\\\"453453453453\\\".\n"
+ "sid=\\\"453453453453453\\\".sid=\\\"4535453453453453453\\\"\n\n"
+ "sid=\\\"786783453533453453\\\"\n"
+ "s[dohj\n"
+ "aspiofbaspfppsid=\\\"453453453453453453453\\\"";
final String subst = "a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}