# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=sid=\\\")\d+(?=\\\")"
test_str = ("sid=\\\"1722407313768658\\\" safklabsf ipashf oiasfoi asbg fasnk sid=\\\"65641\\\" asjobfaosb asbfaosb asf asfauv sid=\\\"651564165\\\" aosibfoasbfoaibsfopaih l;fasbf oiasbfoabop iasbfabsfiogaosuf ou agosufg iuagfi uaf sid=\\\"4191891\\\" auoegfaouf ouah aisfbag iuaeh sid=\\\"51951981\\\". afa[sof afsoi9ha [h .sid=\\\"16518198819198\\\". asfoiiha h'sid=\\\"651848949871698189\\\".\n\n"
"sid=\\\"54637837834534534\\\"\n"
"sid=\\\"172240735345313768658\\\"\n"
"sid=\\\"453453453453\\\".\n"
"sid=\\\"453453453453453\\\".sid=\\\"4535453453453453453\\\"\n\n"
"sid=\\\"786783453533453453\\\"\n"
"s[dohj\n"
"aspiofbaspfppsid=\\\"453453453453453453453\\\"")
subst = "a"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.