#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\btypedef\s+enum\s*{[^}]*)(\w+)\s*=\s*(\w+)(?=[^}]*}\s*foo_t\b)"
Local $sString = "typedef enum" & @CRLF & _
"{" & @CRLF & _
" /** comment */" & @CRLF & _
" A = 1," & @CRLF & _
" /** comment */" & @CRLF & _
" B = 2," & @CRLF & _
"}foo_t;" & @CRLF & _
"" & @CRLF & _
"typedef enum" & @CRLF & _
"{" & @CRLF & _
" /** comment */" & @CRLF & _
" A = 1," & @CRLF & _
" /** comment */" & @CRLF & _
" B = 2," & @CRLF & _
"}bar_t;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")