use strict;
my $str = 'typedef enum
{
/** comment */
A = 1,
/** comment */
B = 2,
}foo_t;
typedef enum
{
/** comment */
A = 1,
/** comment */
B = 2,
}bar_t;';
my $regex = qr/(?<=\btypedef\s+enum\s*{[^}]*)(\w+)\s*=\s*(\w+)(?=[^}]*}\s*foo_t\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}