const regex = /(?<=\btypedef\s+enum\s*{[^}]*)(\w+)\s*=\s*(\w+)(?=[^}]*}\s*foo_t\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\btypedef\\s+enum\\s*{[^}]*)(\\w+)\\s*=\\s*(\\w+)(?=[^}]*}\\s*foo_t\\b)', 'gm')
const str = `typedef enum
{
/** comment */
A = 1,
/** comment */
B = 2,
}foo_t;
typedef enum
{
/** comment */
A = 1,
/** comment */
B = 2,
}bar_t;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}