import re
regex = re.compile(r"(?<=\btypedef\s+enum\s*{[^}]*)(\w+)\s*=\s*(\w+)(?=[^}]*}\s*foo_t\b)", flags=re.MULTILINE)
test_str = ("typedef enum\n"
"{\n"
" /** comment */\n"
" A = 1,\n"
" /** comment */\n"
" B = 2,\n"
"}foo_t;\n\n"
"typedef enum\n"
"{\n"
" /** comment */\n"
" A = 1,\n"
" /** comment */\n"
" B = 2,\n"
"}bar_t;")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")