package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?si)(?:Name:).*(?:Name:)([\s?\w+]*?\n)`)
var str = `Name: Joe blogss forwarded this message
Desc: blah blah
Name: Steve B
Last Line
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}