$re = '/(?si)(?:Name:).*(?:Name:)([\s?\w+]*?\n)/m';
$str = 'Name: Joe blogss forwarded this message
Desc: blah blah
Name: Steve B
Last Line
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);