// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?si)(?:Name:).*(?:Name:)([\s?\w+]*?\n)").unwrap();
let string = "Name: Joe blogss forwarded this message
Desc: blah blah
Name: Steve B
Last Line
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}