const regex = /(?si)(?:Name:).*(?:Name:)([\s?\w+]*?\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?si)(?:Name:).*(?:Name:)([\\s?\\w+]*?\\n)', 'gm')
const str = `Name: Joe blogss forwarded this message
Desc: blah blah
Name: Steve B
Last Line
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}