import Foundation
let pattern = #".*\/\s*(\d+)\s*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1 / 132 / 133 / 134 / 135 / 136 / 137 / 138 / 139 / 1310 / 1311 / 1312 / 1313 / 13
1 / 82 / 83 / 84 / 85 / 86 / 87 / 88 / 8
1 / 152 / 153 / 154 / 155 / 156 / 157 / 158 / 159 / 1510 / 1511 / 1512 / 1513 / 1514 / 1515/ 15
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)