package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([0-9]{5})\b(?:\s|$)`)
var str = `4034 Wells Branch, San Francisco CA 34123
4034 Wells Branch, San Francisco CA 34123-
4034 Wells Branch, San Francisco CA 34123-1234
4034 Wells Branch, San Francisco CA 341231234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}