$re = '/\b([0-9]{5})\b(?:\s|$)/m';
$str = '4034 Wells Branch, San Francisco CA 34123
4034 Wells Branch, San Francisco CA 34123-
4034 Wells Branch, San Francisco CA 34123-1234
4034 Wells Branch, San Francisco CA 341231234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);