const regex = /\b([0-9]{5})\b(?:\s|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([0-9]{5})\\b(?:\\s|$)', 'gm')
const str = `4034 Wells Branch, San Francisco CA 34123
4034 Wells Branch, San Francisco CA 34123-
4034 Wells Branch, San Francisco CA 34123-1234
4034 Wells Branch, San Francisco CA 341231234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}