import re
regex = re.compile(r"\b([0-9]{5})\b(?:\s|$)", flags=re.MULTILINE)
test_str = ("4034 Wells Branch, San Francisco CA 34123\n"
"4034 Wells Branch, San Francisco CA 34123-\n"
"4034 Wells Branch, San Francisco CA 34123-1234\n"
"4034 Wells Branch, San Francisco CA 341231234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")