#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\bSTART\b|\G(?<!\A))(?!.*\bEND\b).*+\K\R"
Local $sString = "some text to not modify" & @CRLF & _
"some pattern on more than one line START" & @CRLF & _
"text to be indented" & @CRLF & _
"or remove indentation maybe ?" & @CRLF & _
"some pattern on more than one line END" & @CRLF & _
"some text to not modify " & @CRLF & _
"---" & @CRLF & _
"some text to not modify" & @CRLF & _
"some pattern on more than one line START" & @CRLF & _
"text to be indented" & @CRLF & _
"or remove indentation maybe ?" & @CRLF & _
"some pattern on more than one line END" & @CRLF & _
"some text to not modify"
Local $sSubst = "\n\t"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)