import Foundation
let pattern = #"(?:\bSTART\b|\G(?<!\A))(?!.*\bEND\b).*+\K\R"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
---
some text to not modify
some pattern on more than one line START
text to be indented
or remove indentation maybe ?
some pattern on more than one line END
some text to not modify
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n\t"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)