import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bSTART\\b|\\G(?<!\\A))(?!.*\\bEND\\b).*+\\K\\R";
final String string = "some text to not modify\n"
+ "some pattern on more than one line START\n"
+ "text to be indented\n"
+ "or remove indentation maybe ?\n"
+ "some pattern on more than one line END\n"
+ "some text to not modify \n"
+ "---\n"
+ "some text to not modify\n"
+ "some pattern on more than one line START\n"
+ "text to be indented\n"
+ "or remove indentation maybe ?\n"
+ "some pattern on more than one line END\n"
+ "some text to not modify";
final String subst = "\\n\\t";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}