#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Redirect 301 /(.+)"
Local $sString = "Redirect 301 /url1 https://ismgroup.ru/url2" & @CRLF & _
"" & @CRLF & _
"Redirect 301 /katalog/dymohody/dymohody-iz-nergaveushei-stali-ferrum/sendvich-truba-ferrum-1-m-f150h210-nergaveushaya-stal https://ismgroup.ru/dyimoxodyi/dyimoxodyi-iz-nerzhaveyushhej-stali-ferrum/sendvich-troinik-90-ferrum-f150h210-nergaveushaya-stal.html" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "RewriteRule ^$1 [R=301,L]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)