$re = '~Redirect 301 /(.+)~m';
$str = 'Redirect 301 /url1 https://ismgroup.ru/url2
Redirect 301 /katalog/dymohody/dymohody-iz-nergaveushei-stali-ferrum/sendvich-truba-ferrum-1-m-f150h210-nergaveushaya-stal https://ismgroup.ru/dyimoxodyi/dyimoxodyi-iz-nerzhaveyushhej-stali-ferrum/sendvich-troinik-90-ferrum-f150h210-nergaveushaya-stal.html
';
$subst = "RewriteRule ^$1 [R=301,L]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;