use strict;
my $str = 'Redirect 301 /url1 https://ismgroup.ru/url2
Redirect 301 /katalog/dymohody/dymohody-iz-nergaveushei-stali-ferrum/sendvich-truba-ferrum-1-m-f150h210-nergaveushaya-stal https://ismgroup.ru/dyimoxodyi/dyimoxodyi-iz-nerzhaveyushhej-stali-ferrum/sendvich-troinik-90-ferrum-f150h210-nergaveushaya-stal.html
';
my $regex = qr~Redirect 301 /(.+)~mp;
my $subst = 'RewriteRule ^$1 [R=301,L]';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";