import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Redirect 301 /(.+)";
final String string = "Redirect 301 /url1 https://ismgroup.ru/url2\n\n"
+ "Redirect 301 /katalog/dymohody/dymohody-iz-nergaveushei-stali-ferrum/sendvich-truba-ferrum-1-m-f150h210-nergaveushaya-stal https://ismgroup.ru/dyimoxodyi/dyimoxodyi-iz-nerzhaveyushhej-stali-ferrum/sendvich-troinik-90-ferrum-f150h210-nergaveushaya-stal.html\n\n";
final String subst = "RewriteRule ^$1 [R=301,L]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}